• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Eclipse - Subclipse - Unable to compare with Tag or Branch

 
Doug Morand
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm using Eclipse and Subclipse with my SVN repository. I'm trying to compare a tag I have checked out versus another tag so I select Compare With -> Branch (or Tag). In both instances I get the following errors:

"There are no tags for resource"
"There are no branches for resource"

Is there something in the Team preferences that I have to configure so that I can compare with other branches/tags?
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 35279
384
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is your repository using teh standard directory structure?
/trunk
/tags
/branches

Also, are you able to view the history of a file in that project?

The answers to these will give more clues as to the problem.
 
Doug Morand
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We are using _trunk _tags and _branches as the folder names. I'm able to view the history on any of the files in the tags/branches I have checked out.
 
Peter Johnson
author
Bartender
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
At what point do you get those errors? Right after clicking "Branch/Tag", or after filling out the "Compare with" dialog?
Also, which version of Eclipse and which version of subclipse?
I can do compares even among files that don't have trunk/branches/tags in their paths in Subversion.
 
Doug Morand
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got it working. I had the wrong version of subclipse instsalled. We have SVN 1.6 so I needed to install this version:

http://subclipse.tigris.org/update_1.6.x

I had installed this one and it wasn't working properly:
http://subclipse.tigris.org/update_1.8.x

Download site: http://subclipse.tigris.org/servlets/ProjectProcess;jsessionid=59E3F12551957114E5CABB27F497A6E8?pageID=p4wYuA

Thanks for the assistance everyone it lead me down the right path to figure this out.
 
Peter Johnson
author
Bartender
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, if you use multiple Subversion clients you must make sure that they are all at the same level, especially if using a 1.7 based client because how the .svn client database is created and managed changed dramatically in that version. (Not sure why subclipse went to version 1.8 for a Subversion 1.7 client, makes it quite confusing to keep things in sync.)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic