• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Problem Creating Project with mvn archetype:create -DarchetypeCatalog=http://tapestry.apache.com

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I installed maven-3.0.4 (also tried with Maven 2.2.1) and tried to create a project with the following command: mvn archetype:generate -DarchetypeCatalog=http://tapestry.apache.org

But I keep on getting the following error:



I tried it on another location, to make sure it's not a poblem because of a proxy blocking the download but i get the same error.
Any help with this would be greatly apreciated.
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I just now tried the same command and it worked for me (asked which archetype and then asked for the artifact coordinates). So I suspect network issues, which is usually one of the following:

a) You are behind a proxy and you need to make proxy settings

b) The Tapestry server was down at the time you tired this (or there was some other temporary network glitch such as DNS being down).

c) You are working in a corporate environment and your IT department has blocked access.
 
Tom Franck
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It's none of the above.
I tried to create it at 3 different locations , on 2 different pc's (worked on a friends pc, but not mine).

Any idea what else it could be?
 
Tom Franck
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Your suggestions made me check if my firewall was off though.
It wasn't turned off properly, so I deinstalled my AVG.

Now it works like a charm, Thankyou!
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Guess I need to add item #4 to my list:

4) Your firewall is blocking outgoing traffic (check your firewall settings). Also, inadvertently blocking is way easier to do than you think. If you ever told your firewall to not allow a specific Java program to to out to the network, you have effectively block all Java programs because the firewall software cannot tell between them (they all run as java.exe).
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic