• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

According to TLD or attribute directive in tag file, attribute test does not accept any expression

 
Ranch Hand
Posts: 65
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am working on a web development project with spring framework. we are using Resin server : resin3.1.12 and having this issue :

According to TLD or attribute directive in tag file, attribute test does not accept any expression



My web.xml file looks like this :

and it is working fine on production server but creating a new project in netbeans with tomcat server(tomcat version 7) and using same code and all other files gives me the above mentioned error.
I tried this solutions, which I found on some blogs :

Reference the correct JSTL uri in your JSP,change



It worked and jsp error was removed.. but its not a feasible solution to change this in all jsp files.
and since the code already working fine, then such kind of changes may create problems on production environment.

Is it a problem with using different server, as I am using tomcat with netbenas and resin 3.1.12 on production environment.
Please suggest me what needs to be done, any kind of help will much appreciated.

Thanks !
 
Sheriff
Posts: 67745
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Your web.xml is wrong. Servlets 2.2? That's ancient!

See the JspFaq for info on declaring the web.xml as a Servlets 2.4 application.
 
vikky agrawal
Ranch Hand
Posts: 65
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Bear Bibeault wrote:Your web.xml is wrong. Servlets 2.2? That's ancient!

See the JspFaq for info on declaring the web.xml as a Servlets 2.4 application.



yes, I tried to change web.xml according to 2.4 specification but it is not working in my case.. I think it may be a problem with server as we are using Resin 3.1.12 on production and I am trying to compile and run using Tomcat 7. on netbeans
As I already mentioned that all this code is working fine on production server.. the problem may be with some specifications that I am not able to locate. :confused:
 
Bear Bibeault
Sheriff
Posts: 67745
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You should be developing with the same server you will use in production. Otherwise, many surprises, none of them pleasant, await.
 
vikky agrawal
Ranch Hand
Posts: 65
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Bear Bibeault wrote:You should be developing with the same server you will use in production. Otherwise, many surprises, none of them pleasant, await.



yes, you are right.. I am facing a lot of problems.. but the thing is code is already developed and I need to create new project with the same code for new enhancements and removing errors.
I tried to incorporate resin with netbeans but was not successfull.. then I switched to Eclipse and there I successfully added resin server but my problems increased there.

The jsp error which I was able to remove in netbens by changing

is not removing in Eclipse. I tried to change web.xml specification also, that too is not working.. now I am clueless how to start work on the code without removing such errors. :confused:
 
Bear Bibeault
Sheriff
Posts: 67745
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You do not need to run from within the IDE. I use my IDE only as a fancy editor and run the web apps separately.
 
vikky agrawal
Ranch Hand
Posts: 65
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Bear Bibeault wrote:You do not need to run from within the IDE. I use my IDE only as a fancy editor and run the web apps separately.



Thanks a lot Bear Bibeault.
I tried without ide and code is working fine.. it saved my lot of time now I can proceed further.

Vikky
 
Bear Bibeault
Sheriff
Posts: 67745
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic