• Post Reply Bookmark Topic Watch Topic
  • New Topic

com.ibm.websphere.ce.cm.ObjectClosedException: DSRA9110E: Statement is closed.

 
J Suk
Greenhorn
Posts: 19
Eclipse IDE Hibernate Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am getting the com.ibm.websphere.ce.cm.ObjectClosedException: DSRA9110E: Statement is closed error in Websphere application server 7.0.0.11.
I tried making the minimum connection to 0 and giving the preTestconnectionpool but did not help. can any one help to get a resolution?

[6/19/12 20:12:36:685 CDT] 00000022 JDBCException W org.hibernate.util.JDBCExceptionReporter logExceptions SQL Error: 0, SQLState: null
[6/19/12 20:12:36:685 CDT] 00000022 JDBCException E org.hibernate.util.JDBCExceptionReporter logExceptions DSRA9110E: Statement is closed.
[6/19/12 20:12:36:873 CDT] 00000022 SystemOut O Hibernate: select this_.SYSTEM_ID as SYSTEM1_4_0_, this_.SYSTEM_NAME_L as SYSTEM2_4_0_, this_.SYSTEM_DESC as SYSTEM3_4_0_ from GRPTLN.TR_SYSTEM this_ where lcase(this_.SYSTEM_NAME_L)=?
[6/19/12 20:12:36:889 CDT] 00000022 AbstractBatch W org.hibernate.jdbc.AbstractBatcher closeQueryStatement exception clearing maxRows/queryTimeout
com.ibm.websphere.ce.cm.ObjectClosedException: DSRA9110E: Statement is closed.
at com.ibm.ws.rsadapter.jdbc.WSJdbcWrapper.createClosedException(WSJdbcWrapper.java:110)
at com.ibm.ws.rsadapter.jdbc.WSJdbcStatement.runtimeXIfNotClosed(WSJdbcStatement.java:1747)
at com.ibm.ws.rsadapter.jdbc.WSJdbcStatement.getMaxRows(WSJdbcStatement.java:1181)
at org.hibernate.jdbc.AbstractBatcher.closeQueryStatement(AbstractBatcher.java:276)
at org.hibernate.jdbc.AbstractBatcher.closeQueryStatement(AbstractBatcher.java:212)
at org.hibernate.loader.Loader.getResultSet(Loader.java:1801)
at org.hibernate.loader.Loader.doQuery(Loader.java:674)
at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Loader.java:236)
at org.hibernate.loader.Loader.doList(Loader.java:2213)
at org.hibernate.loader.Loader.listIgnoreQueryCache(Loader.java:2104)
at org.hibernate.loader.Loader.list(Loader.java:2099)
at org.hibernate.loader.criteria.CriteriaLoader.list(CriteriaLoader.java:94)
at org.hibernate.impl.SessionImpl.list(SessionImpl.java:1569)
at org.hibernate.impl.CriteriaImpl.list(CriteriaImpl.java:283)

Thanks.
 
Jeanne Boyarsky
author & internet detective
Sheriff
Posts: 36027
431
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does this happen on startup of the application or during execution? Every time or after a while. If you try a second time after the error occurs, does it go away?
 
J Suk
Greenhorn
Posts: 19
Eclipse IDE Hibernate Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your reply,
It happens every time I call the webservice operation in my application. Its mainly when a hibernate query is fired in that operation. This application still working fine in WAS6.1 and when we try migrating it in WAS7.0 I am getting this error.
If you can give some hint it will be great.

Thanks a lot.
 
Jeanne Boyarsky
author & internet detective
Sheriff
Posts: 36027
431
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm. Maybe something else is using all the connections? If it worked in WAS 6.1, it might be worth asking IBM.
 
Can't .... do .... plaid .... So I did this tiny ad instead:
the new thread boost feature: great for the advertiser and smooth for the coderanch user
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!