• Post Reply Bookmark Topic Watch Topic
  • New Topic

How to convert jdk1.4 compiler to jdk1.5 compiler?  RSS feed

 
sairam Kukudala
Greenhorn
Posts: 15
Flex Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In my system jdk1.4 is installed and path set to jdk1.4 version in System variables. But when i try to lanch the eclipse3.4 its giving the error message like could not open use jdk1.4 or later version.

I installed java1.5 version and set the path in user variables like

first time i used PATH=C:\Program Files\Java\jdk1.5.0_16\bin and second time PATH=C:\Program Files\Java\jdk1.5.0_16 in both cases getting the same problem

Please give me the solution to run the java programs and lanch the eclipse

FYI: I dont have access rights to change the system variables
 
Greg Brannon
Bartender
Posts: 563
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You may find this article in the Eclipse Wiki helpful. If you're still having trouble, please come back.
 
William P O'Sullivan
Ranch Hand
Posts: 859
Chrome IBM DB2 Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Set your PATH correctly.

At the command prompt, type: java -version

What do you get?

Also, be very very careful of spaces in environment variables, e.g: "program files".
Surround with quotes " to be on the safe side, or use a custom install and put jdk1.5 in
something like "c:\jdk-1.5" etc..

Also look for JAVA_HOME, JAVA_OPTS etc.

WP
 
sairam Kukudala
Greenhorn
Posts: 15
Flex Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
William P O'Sullivan wrote:Set your PATH correctly.

At the command prompt, type: java -version

What do you get?

Also, be very very careful of spaces in environment variables, e.g: "program files".
Surround with quotes " to be on the safe side, or use a custom install and put jdk1.5 in
something like "c:\jdk-1.5" etc..

Also look for JAVA_HOME, JAVA_OPTS etc.

WP


when i set the path at command prompt always i am getting jdk1.4 and i am sure about the path(copy and paste)
 
Steve Fahlbusch
Bartender
Posts: 612
7
Mac OS X Python
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK -- from the posts above, did you quote the path or simply copy and paste ---- windows does not like folder names with spaces.

Just so that you "get it" /program files/ is not a directory as far as environment variables go.
 
Campbell Ritchie
Marshal
Posts: 56534
172
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why on earth are you using a version of Java which has been officially obsolete for 2½ years?
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!