Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

NoClassDefFoundError with org.apache.struts.action.ActionServlet looking for PlugIn class in package  RSS feed

Sean Wachter
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Good I've recently upgraded my Struts application from version 1.2 to 1.3.8. My applicaiton utilizes SpringFramework 3.0.6 and I'm running in WAS 8.0 and a configuration having a Multiple classloader policy defined. My application builds fine but when I go to deploy the application I recieve a NoClassDefFoundError during my servlet initialization.

I've played with my classpath for days trying to resolve the missing dependancy and I'm unable to resolve it. I've tried myultiple classpath configurations with my Struts libraries located in my EAR project lib/ folder as well as locating them in my WEB application WEB-INF/lib folder. I get the same result in both locations.

What is really wierd here is when I search for where the classes are located in my workspace the struts ActionServlet class is in the exact same Jar (struts-core-1.3.8.jar) and even package (org.apache.struts.action) as the class that the classLoader cannot find PlugIn. How can Websphere find my org.apache.struts.action.ActionServlet class to start to init() it, but cannot find the org.apache.struts.action.PlugIn class located in the same JAR? What might I be doing wrong here?

My servlet Initialization code in com.lmig.ecm.claimoverview.web.servlets.ClaimOverviewActionServlet.init( is simply calling a super.Init()

Thank you in advance for any suggestions or direction you might be able to provide.

  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!