Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Exception created:com.ibm.websphere.servlet.error.ServletErrorReport: java.lang.NoClassDefFoundError

 
anu jose
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am migrating an application from Websphere application server 6.1 to 7 (Structs framework). Here I need to load an image (java applet). While clicking on the link to load image (a separate page) i am getting page not found. the error in console is
Exception created : com.ibm.websphere.servlet.error.ServletErrorReport: java.lang.NoClassDefFoundError:<classfile>(initialization failure)

for one of the class file which is in a jar. I have included the jar In EAR. And also tried adding in the WAS admin console class path. the class file is present and it is pointing to correct jar when I checked in the file where it is imported/used. But I am getting the above error always. Can anybody help me ? thanks in advance. let me know if you need anymore details.
 
Paul Clapham
Sheriff
Posts: 21319
32
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There should be more information in the logs. In particular that "(initialization failure)" should have produced its own stack trace. See if you can find that.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic