Win a copy of OCP Oracle Certified Professional Java SE 11 Developer Practice Tests this week in the OCP forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Ron McLeod
  • Tim Cooke
Sheriffs:
  • Devaka Cooray
  • paul wheaton
  • Mark Herschberg
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Frits Walraven
  • Jj Roberts
Bartenders:
  • Carey Brown
  • salvin francis
  • Piet Souris

Authentication Using Tomat Not Working

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dear all,

I am trying to implement the authentication using Tomcat config. after edit the web.xml I couldn't Run the Application. This is My web.xml file



When I run the Application I got this Error.

 
Marshal
Posts: 26377
81
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm not sure why your post title mentions "authentication" when you have no evidence at all that authentication is the cause of the failure. It's never a good idea to make evidence-free decisions like that, since it's likely to make you look in the wrong place for the actual problem.

Anyway you should start with the only piece of evidence you do have, the small log file at the end of your post. Pay particular attention to this line:

See the server log for details.



because it tells you how to find more information about the actual problem.
 
Sirojan Gnanaratnam
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi paul,

In My Server Log Nothing Is printed . as well as Tomcat Starting is Failed When I deploy or start using web Services Tab In Netbeans..
 
Paul Clapham
Marshal
Posts: 26377
81
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Then set that XML file back to the previous version from your source control which you know works. Use that to start Tomcat, and then look for the log files. Make sure you know where to find them, so the next time an error message tells you to look at them, you know where they are.
 
Happiness is not a goal ... it's a by-product of a life well lived - Eleanor Roosevelt. Tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic