This week's book giveaway is in the Artificial Intelligence and Machine Learning forum.
We're giving away four copies of Zero to AI - A non-technical, hype-free guide to prospering in the AI era and have Nicolò Valigi and Gianluca Mauro on-line!
See this thread for details.
Win a copy of Zero to AI - A non-technical, hype-free guide to prospering in the AI era this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Paul Clapham
  • Bear Bibeault
  • Jeanne Boyarsky
Sheriffs:
  • Ron McLeod
  • Tim Cooke
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Jj Roberts
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • salvin francis
  • Scott Selikoff
  • fred rosenberger

iFrame loading fine in all browsers except IE9.

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am facing an issue wherein an iframe(with a jsp page loaded inside) does not work fine in IE9 alone but it works fine in IE7,IE8 and even other browsers.
The functionality is like I give certain inputs submit the page and a result page appears. In the result page, there are several records and for each record, there is a details button.
When I click on the details button, the details for that particular record is displayed.
When I click on the details button, a javascript function is called on the onclick event of the button.
The javascript sets the iframe as the target for the results to get loaded and then submits the results page.
When the results page is submitted, a STRUTS call is made and another JSP page with details gets loaded inside the target iframe.
In all other browsers, the iframe with details(jsp page) is displayed perfectly, but in IE9 the iframe is displayed but the details inside the iframe is not displayed.

NOTE: The SRC attribute of iframe loads a blank.html page and it does not change even after the page is submitted and only the details from another jsp page gets loaded inside this iframe but the SRC attr does not change.

Few Imp points:
1. When I change the id attribute of the iframe using IE9 developer tool, the details are displayed but when this code is deployed in the server, the code fix does not work.
2. Refreshing the iframe was tried, but I was not successful.
3. I tried replacing the iframe with <div>, <frameset>, and <object> tags but I could not get the same look and feel of the iframe as I get in other browsers.
4. I tried to make my page in IE9 backward compatible to IE7 or IE8 using <META ... content="EmulateIE8"> but was not successful.

Request you to give your views on fixing this issue.
Appreciate your patience in going through the whole issue above.
 
author
Posts: 15385
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So you wrote a lot of stuff, the best ting you could do is write a basic code that demonstrates the problem/what you are doing.

Eric
 
Please enjoy this holographic presentation of our apocalyptic dilemma right after this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic