Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

All glassfish 3.1.1 login modules stopped working  RSS feed

Erwin Erwinowski
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
I have encounter a major problem in my Glassfish container

I successfully configured basic authentication with jdbcRealm, which was working ok for about a week. Unfortunately I specified wrong number of available connections to database and soon I received "too many connections for user" error from database. I have killed all connections, changed number of available connections in JDBC connection pool, restarted container... And then everything started.

I can successfully ping my database, No jdbcRealm configurations were changed and while login in secure realm I constantly receive:

But the funny thing is that during startup Glassfish reports that login modules are loaded corretly

I thought that maybe jdbcRealm configuration is wrong so I tried fileRealm. With the same effect of "no login module configured...", moreover when I tried admin commands from command line (asadmin) which demand admin login I received "no login module configured for adminRealm"

my login.conf looks ok

How colud I destroy configuration of all my login modules?
I have already googled it several times.
I will realy appreciate any help. Thanks in advance
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!