Win a copy of Bad Programming Practices 101 (e-book) this week in the Beginning Java forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

problem in struts  RSS feed

 
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i am using netbeans 6.1 with tomcat 6.0 of strut 1.2.9.

index.jsp contains
<jsp:forward page="Welcome.do"/>

my strutsconfig.xml contains




but when i run the program as giving the url as
http://localhost:8080/Sample/

it gives 404 error. what will be error
 
Ranch Hand
Posts: 349
Eclipse IDE Hibernate Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think the problem may be in your web.xml, do you have your index.jsp mentioned in the web.xml? Have you mentioned the servlet-name within servlet-mapping like,




Ananth Chellathurai
 
Ranch Hand
Posts: 2907
1
Java Spring Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Look at the welcome-file-list tag in your web.xml, it may not be correctly defined !
 
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Like Ananth said , check web.xml. See if you have defined some index.jsp as welcome file or not?
 
Don't mess with me you fool! I'm cooking with gas! Here, read this tiny ad:
Why should you try IntelliJ IDEA ?
https://coderanch.com/wiki/696337/IntelliJ-IDEA
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!