• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Devaka Cooray
  • Ron McLeod
  • paul wheaton
Saloon Keepers:
  • Tim Moores
  • Piet Souris
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Frits Walraven
  • Scott Selikoff

How to start in the project in debug mode.

 
Greenhorn
Posts: 25
Hibernate Eclipse IDE
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am working in a project where we are using RMI,JMS,Swing etc .

What i need is to start the project in debug mode.

So, to start the application we are starting 3 .bat files . here are the bat files.
1)setclassPath.bat

2)startRMI.bat


3)Startapplication.bat



So can any suggest me how to start project(server and client ) in debugging mode . Here i need to put some break points and test the application.

 
Bartender
Posts: 6109
6
Android IntelliJ IDE Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator


address = whatever port you want, just have your debugger connect to that port

suspend = y if you want the app to wait for the debugger to connect before starting, n if it can run free until the debugger connects
 
silamala ramesh babu
Greenhorn
Posts: 25
Hibernate Eclipse IDE
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Jeff,

Thank you for you reply .

Might be you reply will work but i am not able to make use of that. Here i am providing more details.

i am using Eclipse and ANT to build the project and after the build success full i am opening the cmd prompt and running the the batch file which i gave in my previous thread.

First i am running the startRMI.bat file in which the serverApplication.java is starting and after some 2 mins i am running the StartApplication.bat file in which the ClientApplication.java is starting.

After running the StartApplication.bat file my apllication is launching.

So to run the application in Eclipse i did the following

1)Ran the startRMI.bat manually from the cmd prompt
2) in stead of running the StartApplication.bat
Here i copied the VM arguments present in the StartApplication.bat file and put in Eclipse debug configurations and tried to start the ClientApplication.java in debug mode.But its not working
The VM arguments i put in Eclipse debug configurations are


I am getting the following error in the eclipse console

java.lang.NoClassDefFoundError: java
Caused by: java.lang.ClassNotFoundException: java
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
Exception in thread "main"
 
Uh oh, we're definitely being carded. Here, show him this tiny ad:
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic