This week's book giveaway is in the Java in General forum.
We're giving away four copies of Event Streams in Action and have Alexander Dean & Valentin Crettaz on-line!
See this thread for details.
Win a copy of Event Streams in Action this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Connecting to Tomcat from another machine

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello All,

I am relatively new to Apache Tomcat so please excuse my ignorance.

Ok here is the situation. I have two virtual machines (VMs) running on a single network. One machine is running Fedora 11 (F11) and the other is running BackTrack5 R2 (BT5). I have installed Apache Tomcat on F11, locally. I am able to access the Tomcat Manager from the F11 machine just fine by using the following URL:

http://localhost:8080



However, when I try to access the Tomcat manager from the BT5 VM, I receive a "Unable to Connect: Problem Loading page" error in Firefox. I am trying to access the F11's tomcat manager through the following URL:

http://<ipaddress>:8080



However, as stated above, this is not working. Do I need to enable some setting on my F11's Tomcat in order to access it from another machine? Or am I just an idiot and missing a crucial step?

Any advice is certainly appreciated.

Thanks,

Bryce

EDIT: The version of Tomcat I am running is 5.5.27

 
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just asked the same question couple of days ago (http://www.coderanch.com/t/595744/Tomcat/Tomcat-access), it all really depends on how you are connected to the internet. If you have a router, then check router settings and enable port forwarding to 8080. I had to add "service" on specific pc (with specific IP address, port, etc), but it all depends on what router vendor and software you are using. Otherwise, simply enable port forwarding to 8080 in your firewall settings, or use iptables (although, I'm not sure how to use that one).
 
Dan Felbman
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm. Okay, well I am not sure how to enable port forwarding but it most likely is being done in iptables from what I have read.

I have added the following line in iptables:



Still not working though. Also, I am not sure if I can edit my router settings as this is in a pre-configured VLAB that I dont have access to the settings. I will double check with my administrator though. Is there any way that I can test to see if port forwarding is on? I have tried telnet on the VP but I don't receive a response.

Any ideas?

Thanks for your help
 
Bartender
Posts: 20934
127
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think that your rule is too restrictive. Try:


I usually end up my IPTABLES with a -A INPUT -j LOG right before the final drop as a confirmation that things are (and aren't!) getting allowed through.

If there are filtering and/or forwarding options in the router, I can't help you. That's very product-dependent.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!