• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

taglib not working in error page

 
chiku awasthi
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am facing a problem where taglibs are not working in error page, if the error page is accessed directly from browser it is displayed correctly,
but when it is executed due to an exception none of the laglibs are executed. Any help in this regard will be very much appreciated.

Thanks,
Shrey
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65229
95
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please read ItDoesntWorkIsUseless and supply the missing information.
 
chiku awasthi
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for pointing me in right direction :), all I am getting in the error page (when invoked after an exception is thrown) is simple text, none of the properties included in the tag libs are working,
example <security:authentication> or <c:if> or even CSS formatting, but when I access the page directly all the tags and css formatting is getting evaluated correctly.

Thanks.
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65229
95
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are the tags simply not being interpreted? What's sent to the browser (View Source)? Are there any errors in the logs? How are you configuring the error page? These are all things we need to know.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic