Win a copy of 97 Things Every Java Programmer Should Know this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

Weblogic - JNDI Datasource Lookup Issues

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have an applet that attempts to do a JNDI lookup on a given data source and then once the data source is found use the associated db connection.

Here is my code:


I have created a jar file from this class and signed it. I need some classes in the weblogic.jar and wlthint3client.jar archives so I signed those as well.

When I run the using the applet viewer (C:\Work\Applet_Test\viewer>appletviewer -J-classpath -Jweblogic.jar;wlthint3client.jar t.html) I get the following exception:



When I run from a browser I accept the certificate and the applet just hangs where the InitialContext is instantiated.

This seems to be security related but having signed my jars I don't know what else it could be looking for.

Any ideas?

Thanks...

 
No one can make you feel inferior without your consent - Eleanor Roosevelt. tiny ad:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic