• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

My Java Web Start has completely disappeared and I cannot run .jnlp files

Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have had an issue with running .jnlp files. At one point, I was able to select a link and they worked fine. Then one day, they did not work at all.

Java scripts through the browser does work (example: http://phet.colorado.edu/en/simulation/plinko-probability -> "Run Now") So, when I have java.com run to see if java is working, it says everything is fine.

An example of my issue is: I select "Run Now" (http://phet.colorado.edu/en/simulation/forces-and-motion-basics) and the only thing that happens is it saves a file in my download folder. When I try to choose program, the Java Web Start option is not available. Moreover, I can't find javaws anywhere.

I tried all the suggestions that Oracle and my tech person mentioned. I uninstalled all versions of java. I re-installed both the 32-bit and 64-bit version with no success. I have tried to uninstall and re-install my browsers with no luck.

Any help would be greatly appreciated.
Posts: 3837
Netbeans IDE Oracle Firefox Browser
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Welcome to the Ranch, Mike!

javaws.exe is present in the bin directory (next to java.exe) in my Java 6 JRE installation. I've just installed a freshly downloaded version of Java 7, and it contains javaws.exe in the same location. I don't understand why it is missing in your system. However, some security flaws in Java connected to web were reported recently, and some vendors have disabled Java in their browsers. I'd check with your antivirus software to see whether it doesn't prevent you from accessing the javaws.exe; I'd say it's unlikely, but possible.

Edit: Javascript is completely unrelated to Java. Even without any version of Java installed, Javascript can run in a browser. That Javascript is running on your computer therefore doesn't say anything about the condition of Java.
pie. tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
    Bookmark Topic Watch Topic
  • New Topic