Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Maven Error - could not resolve dependencies for project

 
ParagM Pmahajan
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi ,

I am following the steps given at :

http://seleniumhq.org/docs/03_webdriver.jsp#java

When I run 'mvn clean install' , I get following error :

[ERROR] Failed to execute goal on project MySel20Proj: Could not resolve dependencies for project MySel20Proj:MySel20Proj:jar:1.0: Failed to collect dependencies for [org.seleniumhq.selenium:selenium-java:jar:2.28.0 (compile), com.operaperadriver:jar:1.1 (compile)]: Failed to read artifact descriptor for org.webbitserver:webbit:jar:0.4.14: Could not transfer artifact org.sonatype.ossss-parent:pom:6 from/to central (http://repo.maven.apache.org/maven2): Read timed out -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

I am new to Maven and hence need some help to solve this .
Do I need to change my pom.xml ?

Thanks a lot .
 
Jayesh A Lalwani
Rancher
Posts: 2756
32
Eclipse IDE Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you post a few more lines from the log before that error? You will see logs where it says that it is trying to download dependencies from the maven repo. Does it say its successful? If not, can you try copying that URL and pasting into your web browser?

The problem could be that you are unable to connect to the maven repo, so the build cannot download the dependency. It could be a network glitch or a persistent problem. You will have to first check if you are able to connect to the repo.
 
ParagM Pmahajan
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looks like it was a network issue , I tried again and it was successful !
Thanks anyways for your help.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic