• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Apache axis2 and Rampart not preventing 'replay attacks'

 
Roger manning
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

We use one of the older versions of apache axis2 for our web services framework. We are using rampart 1.2 as part of that.

Am trying to use password digest with ‘nonce’ and ‘timestamp’ mechanism for authentication. We’re getting rampart to do the verification.
I’ve got the authentication verification mechanism working fine (inc. password callbacks, etc.)

The issue I’m having concerns getting rampart to recognise a ‘replay attack’, basically the functionality of the rampart module associated with recognising these seems to be inactive.
I can send the same security header to my axis2 service any number of times (even sending a security header I generated yesterday) and it authenticates fine and completes the webservice request.

My best guess is : I’m missing a config setting somewhere for the rampart module that enables the functionality to detect replay attacks.
I’ve tried both the config suggestions given in the links below (in the services.xml file) and neither seem to work :-
http://hasini-gunasinghe.blogspot.com.au/2012_02_01_archive.html
http://axis.apache.org/axis2/c/rampart/docs/configurations.html (right at the bottom, it mentions ‘Replay attacks’)

Anyone able to help or give me some idea what I'm missing and where (I'd imagine it's config setting related) ?

I've got the module declaration for rampart in my axis2.xml file :-


And I have what I believe to be the rampart config settings in my services.xml file after all my operations are declared ;-
 
Ulf Dittmer
Rancher
Posts: 42969
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can't speak to the ReplayDetection feature, but there used to be a timeToLive element in the parameter/action section that would allow you to specify how long security credentials were good - something like "<timeToLive>10</timeToLive>" - in conjunction with a parameter/action/items: Timestamp. That would prevent such attacks after "timeToLive" seconds have passed. Not the same, but a start.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic