Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Struts 2 Validation stopped working mysteriously (First Struts2 Project)

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm working on my first Struts2 project and I am having an issue getting the validation to work. It was actually working great last night, but when I opened up Eclipse today it is mysteriously skipping validation altogether... no error messages or exceptions. I haven't changed anything. The validation xml is in the same package location at the action file.

I also tried importing a WAR file with working code that I created last night, although when I imported the working code, the validation still doesn't work... I'm at a bit of a loss.

I am trying to validate that the Operating System and OS Version fields are required and the Notes field is optional, but now it's executes the add method and adds the data to the database.

Anything I might be missing here? Any help would be much appreciated.


OsAction.java


OsAction-validation.xml



struts.xml



entry.jsp



result.jsp
 
reply
    Bookmark Topic Watch Topic
  • New Topic