Win a copy of Penetration Testing Basics this week in the Security forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Spring with Atomikos Error - XAER_DUPID: The XID identifies an existing transaction

Fernando Franzini
Ranch Hand
Posts: 489
Java Spring Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Folks

I configured an existing solution JSF 2, JPA with SPRING with Atomikos JTA .... but this error is occurring:

When I run a bean method with only 1 insert, the error does not appear .. when I run a bean method occurs with 2 or more insert, the error happens.
I have several bean, calling other beans.insert () all with @ Transactional ... It seems that Spring is not able to properly propagate internal transactions other beans ....
This solution was already running transactions using JpaTransactionManager ... but when I configured the JtaTransactionManager stopped working ...
My spring xml:

Could someone help me?
Best Regards.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic