• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

Spring with Atomikos Error - XAER_DUPID: The XID identifies an existing transaction

 
Ranch Hand
Posts: 497
2
Spring Java Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello Folks

I configured an existing solution JSF 2, JPA with SPRING with Atomikos JTA .... but this error is occurring:



When I run a bean method with only 1 insert, the error does not appear .. when I run a bean method occurs with 2 or more insert, the error happens.
I have several bean, calling other beans.insert () all with @ Transactional ... It seems that Spring is not able to properly propagate internal transactions other beans ....
This solution was already running transactions using JpaTransactionManager ... but when I configured the JtaTransactionManager stopped working ...
My spring xml:



Could someone help me?
Best Regards.
 
reply
    Bookmark Topic Watch Topic
  • New Topic