Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

IntelliJ 12 not working correctly with JDK 1.7  RSS feed

Ryan McClain
Ranch Hand
Posts: 153
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I try to run my project (Shift+F10/play button) in IntelliJ 12 Ultimate using JDK 7 update 7, I get the following error:
Java:System Java Compiler was not found in classpath

I tried to manually add my JDK\bin path to the path environment variable in Windows, rebooting. Still didn't help. I got the same error.
I also added JDK7u7 under every part of Project Structure where one could select a JDK.
However, when I change from JDK7u7 to JDK6u27 then all of a sudden my project compiles without problems.

I want to be able to run my project with JDK7u7. How do I do that?

OS: Windows 7 x64
Java versions: JDK 1.7u7 i586 32 bit, JDK 6u27 i586 32 bit


It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!