Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Exception: Unrecognized SSL message, plaintext connection?

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

This is my first time I use SopaUI (version 4.5.1) and I try to use it for testing a client WS.
My client simply sends a request to a local server (http://localhost:8070/test) I set up via SoapUI.

These were my steps:
1. I created server and client certificates as below:

keytool -genkey -alias server -keyalg RSA -validity 3650 -keystore c:\server.keystore -storepass abcd1234 -keypass abcd1234
keytool -export -alias server -keystore c:\server.keystore -storepass abcd1234 -file c:\server.cer

keytool -genkey -alias client -keyalg RSA -validity 3650 -keystore c:\client.keystore -storepass abcd1234 -keypass abcd1234
keytool -genkey -alias client -keyalg RSA -storetype PKCS12 -keystore c:\client.p12 -storepass abcd1234 -keypass abcd1234
keytool -export -alias client -keystore c:\client.p12 -storetype PKCS12 -storepass abcd1234 -file c:\client.cer
keytool -import -alias server -keystore c:\client.keystore -storepass abcd1234 -file c:\server.cer
keytool -import -alias client -keystore c:\server.keystore -storepass abcd1234 -file c:\client.cer

2. In Soap UI I set up both certificates in File->Preferences->SSL Settings page (please see the attached file 'SSL settings.jpg').

3. I created a SoapUI project via WSDL and I create a SOAP12 Binding Mock Service to simulate server response and started it

4. If I run an HTTP request the execution will be ok (please see attached file 'http request.jpg), while I will get the error 'Error getting response; Unrecognized SSL message, plaintext connection?' if I try to send an HTTPS request (please see attached file 'https request.jpg').

I also tried to add both certificates in Project View -> WS-Security Configurations -> Keystores TAB but the result was the same.
I also tried to send both requests from a Spring test project, but I got the same result.
Then, I have supposed there is something wrong on server side.
May someone help me in find out what is wrong in my settings?

Thank you so much.
http-request.JPG
[Thumbnail for http-request.JPG]
https-request.JPG
[Thumbnail for https-request.JPG]
SSL-settings.JPG
[Thumbnail for SSL-settings.JPG]
 
Squanch that. And squanch this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic