Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JMS Messages stuck in queue with status 'receive'

Nilesh Nalawade
Posts: 1
Eclipse IDE Oracle Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I have an application which is deployed on WebLogic server. We have not used any third party JMS jars and its only that comes with WL server. All my queues have been configured to with parameters as 'Redelivery Delay Override: -1', 'Redelivery Limit: -1'

During testing of application, JMS messages are frequently getting stuck in the queue. Status of the message says 'receive' and the message is never consumed by the application code.

I am not sure why is this happening? Does it have anything to do with the Web Logic version that I am using?
All the times we needed to delete Filestore and recreate the message.

I have came across some article while hunting for the cause of issue. As per that article WL10.3 has this bug and a temporary fix would be as below:

"We need to define connection-factory-jndi-name” in “weblogic-ejb-jar.xml” along with setting MaximumMessages to 1 . This somehow makes this issue go away. After these changes the messages get allocated to a free consumer!!"

Can somebody please suggest what could be the real cause of issue and its solution?
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic