Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

How can i change the context on JBOSS EPP 5.2.2 With Publisher

 
Felipe Rivera
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello guys, i have a seriously problem with JBOSS
i am tried to change the context but it doesn't work

I put this code on the application.xml of my EAR file

*I have two WAR inside my EAR, so i changed the name on both*


Before Changes localhost:8080/ecmdemo/classic

after changes localhost:8080/gustavo/classic

i have changed the context in the file ROOT.war\WEB-INF\jboss-web.xml, too.




The problem is that the web page doesn't load the images and the scripts, if i open an image in a new_tab show this

http://localhost:8080/ecmdemo/rest-ecmdemo/jcr/repository/collaboration/sites%20content/live/classic/web%20contents/site%20artifacts/Logo/medias/images/Logo.gif

but if i change to this, then i can see the imagen
http://localhost:8080/gustavo/rest-ecmdemo/jcr/repository/collaboration/sites%20content/live/classic/web%20contents/site%20artifacts/Logo/medias/images/Logo.gif

What could be the problem? I imagine than should exist some file responsible of managment URL.




*This is the content of my EAR*


 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm confused. You wrote that you changed the context from the default of "ecmdemo" to "gustavo" and then when you use http://xxx/ecmdemo/xxx it doesn't work but when you use http://xxx/gustavo/xxx then it does work. Frankly, that is what I would have expected - you can now use the context that you defined. Is there a typo in your post???
 
Felipe Rivera
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Peter Johnson wrote:I'm confused. You wrote that you changed the context from the default of "ecmdemo" to "gustavo" and then when you use http://xxx/ecmdemo/xxx it doesn't work but when you use http://xxx/gustavo/xxx then it does work. Frankly, that is what I would have expected - you can now use the context that you defined. Is there a typo in your post???


the problem is that the images and scripst don't load ,

the initial webpage http://xxx/gustavo/xxx


when i open a imagen in a new tab


when i change the context in the URL



that is my problem

by the way sorry for my english , greetings from chile.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic