Win a copy of Programming with Types this week in the Angular and TypeScript forum
or The Design of Web APIs in the Web Services forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Knute Snortum
  • Henry Wong
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Joe Ess
  • salvin francis

After WAS 7.0 to WAS 8.5: ScannerContextImpl getInputDataForClass Failed to open resource

 
Rancher
Posts: 3541
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I have migrated application from Java EE 1.4 to Java EE6, and trying to run it in WAS 8.5.

Servers log show some error during deployment (deploying from RAD 8.5), however application works fine.

It seems that some annotations processor can not load servlet class (???). The application does not use any annotations (it was ported from Servlet 2.4), so it's OK. The error repeats for all servlets in web app.

Any help is appreciated.

Version of WAS:


WebSphere Platform 8.5.0.1 [BASE 8.5.0.1 cf011242.02] running with process name XXXCell\YYYNode\server1 and process id 3248
Host Operating System is Windows XP, version 5.1
Java version = 1.6.0, Java Compiler = j9jit26, Java VM name = IBM J9 VM



Typical error messages:


[24.4.13 12.35.39:225 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Failed to open resource [ XXXXXXXServlet.class ] from module [ BBBBB.war ]
[24.4.13 12.35.39:225 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ org.eclipse.jst.j2ee.commonarchivecore.internal.util.WarFileDynamicClassLoader@2eee11a8 ]
[24.4.13 12.35.39:225 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ com.ibm.ws.bootstrap.ExtClassLoader@9c966e14 ]
[24.4.13 12.35.39:225 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader@19a76051 ]
[24.4.13 12.35.39:225 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ sun.misc.Launcher$AppClassLoader@9e123232 ]
[24.4.13 12.35.39:225 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ sun.misc.Launcher$ExtClassLoader@8786f9ff ]
[24.4.13 12.35.39:241 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Failed to open resource [ YYYYYYYServlet.class ] from module [ BBBBB.war ]
[24.4.13 12.35.39:241 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ org.eclipse.jst.j2ee.commonarchivecore.internal.util.WarFileDynamicClassLoader@2eee11a8 ]
[24.4.13 12.35.39:241 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ com.ibm.ws.bootstrap.ExtClassLoader@9c966e14 ]
[24.4.13 12.35.39:241 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader@19a76051 ]
[24.4.13 12.35.39:241 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ sun.misc.Launcher$AppClassLoader@9e123232 ]
[24.4.13 12.35.39:241 FET] 00000048 annotations W com.ibm.ws.amm.scan.context.ScannerContextImpl getInputDataForClass Class loader [ sun.misc.Launcher$ExtClassLoader@8786f9ff ]

 
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,

I have new portal 8.0 theme deployed and when ever I deploy the theme or restart the EAR I see these errors in my logs. Did you find any solution for this ?
 
Mikalai Zaikin
Rancher
Posts: 3541
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Revanth Sharma wrote:hi,

I have new portal 8.0 theme deployed and when ever I deploy the theme or restart the EAR I see these errors in my logs. Did you find any solution for this ?



Not yet. Please, share solution here if you find one. Thanks.
 
Mikalai Zaikin
Rancher
Posts: 3541
37
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It seems IBM released a fix for this annoying problem. It's a warning, not an error, so was not very critical...

A person needs FixPack 13 (or higher) for WAS 8.5.5, or a FixPack 5 (or higher) for WAS 9.0

Details here: http://www-01.ibm.com/support/docview.wss?uid=swg1PI82698
 
Our first order of business must be this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!