• Post Reply Bookmark Topic Watch Topic
  • New Topic

Not able to invoke UI in an IPv6 network  RSS feed

Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I have an issue in invoking UI on unix. We used different x-servers but still not able to invoke UI. We are working in IPv6 network. When invoking UI it gives error –
Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using 'blrkec255673d:0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)

Export variable is set explicitly. Same works fine in IPv4 network.
Also, if I do a ‘telnet’ from unix to the windows port where my x-server is running, it gives me error as – connection refused. I am able to ‘telnet’ to other ports on windows from unix. I tried with different x-servers, ‘telnet’ to the ports where x-server is listening is not happening in all cases.
Any suggestion/help would be appreciated. We are stuck on this.

It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!