• Post Reply Bookmark Topic Watch Topic
  • New Topic

Second level menu is not working for mouse click after installing jrE1.7

 
Divya Kumar
Greenhorn
Posts: 16
Eclipse IDE IntelliJ IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys,
need urgent help.
I have a JAVA Swing application.
After installing JRE1.7 my second level menu items(mainMenu->submenu->menuitem) is not working for mouse event .
they were working good incase of Jre1.6

Regards
Divya Kumar
 
Campbell Ritchie
Marshal
Posts: 52587
119
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We never use the word urgent. You would have to provide a lot more details before anybody can help.
 
Divya Kumar
Greenhorn
Posts: 16
Eclipse IDE IntelliJ IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have installed JRE1.7 on my machine.I am not getting any kind of exceptions.
But my menus are not working with mouse click but they are working with keyboard .
There is no specific scenario.
My application is Swing application and it's working fine with JRE1.6
 
Campbell Ritchie
Marshal
Posts: 52587
119
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That still isn't enough detail, I am afraid.
 
Divya Kumar
Greenhorn
Posts: 16
Eclipse IDE IntelliJ IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rithcie,
I can understand your concern
I am posting a piece of code for reference.
Please let me know if have got any clue.
I think It has some problem but Iam not able to figure it out.
 
Divya Kumar
Greenhorn
Posts: 16
Eclipse IDE IntelliJ IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Guys,
I digged inside the code and find and have following observations

Action performed is not getting called in this case.

Then I tried with mouseListener, And observed that mouse clicked is not fired.
But Mouse pressed got called bot NO mouse released.

I think My menu list is getting disposed before mouse release is fired and hence mouseClicked and actionPerformed is not fired.
 
Rob Camick
Ranch Hand
Posts: 2700
10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is the problem with the JDK or your code?

Try running the MenuDemo code from the Swing tutorial on How to Use Menus to see what happens.
 
Divya Kumar
Greenhorn
Posts: 16
Eclipse IDE IntelliJ IDE Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Rob,
That what I am trying to figure out bcz Demo code is running fine.
But same code was working fine with JDK1.6.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!