[Logo]
Forums Register Login
Unable to generate custom WSDL - Axis2


Hi All,

I am trying to generate WSDL based on existing custom WSDL provided. Custom WSDL was validated using SOAPUI. It generates operations perfectly.
However, when deployed this WSDL within EAR it is not getting recognized by axis2.

We have tried deploying custom WSDL & Schema (XSD) in EAR as follow
1. EAR->WAR->WEB-INF->services->AAR->META-INF->custom wsdl, xsd, services.xml
2. EAR->WAR->WEB-INF & xsd->services.xml,wsdl.

Note: we had kept useoriginalwsdl = true in services.xml for all above cases.
We didn't receive any error in deployment however we received message as Unable to generate WSDL 1.1 for this service If you wish Axis2 to automatically generate the WSDL 1.1, then please set useOriginalwsdl as false in your services.xml

We also had kept service name from WSDL,EAR name, WAR name, WSDL name and Service name from services.xml same.

Can anyone provide exact deployment structure of custom WSDL with EAR for Axis2?
It is bit urgent.
Can anyone kindly help on this issue? It is bit urgent.
Did nobody ever tried deploying web services using axis2 custom wsdl approach?
Wink, wink, nudge, nudge, say no more ... https://richsoil.com/cards



All times above are in ranch (not your local) time.
The current ranch time is
Nov 19, 2017 07:23:38.