• Post Reply Bookmark Topic Watch Topic
  • New Topic

tnameserv error in new Java build  RSS feed

 
J McCarch
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just built Java 7 from source on SLES 10 AND 11 systems (separately), and when I try to start tnameserv to run the JCK tests I am getting the following error on both systems:

Exception in thread "main" java.lang.ExceptionInInitializerError
Caused by: java.util.MissingResourceException: Can't find com.sun.corba.se.impl.logging.LogStrings bundle
at java.util.logging.Logger.setupResourceInfo(Logger.java:1406)
at java.util.logging.Logger.<init>(Logger.java:262)
at java.util.logging.LogManager.demandLogger(LogManager.java:396)
at java.util.logging.Logger.demandLogger(Logger.java:321)
at java.util.logging.Logger.getLogger(Logger.java:414)
at com.sun.corba.se.spi.orb.ORB.getCORBALogger(ORB.java:493)
at com.sun.corba.se.spi.orb.ORB.staticGetLogger(ORB.java:485)
at com.sun.corba.se.spi.orb.ORB.staticGetLogWrapper(ORB.java:523)
at com.sun.corba.se.impl.logging.NamingSystemException.get(NamingSystemException.java:51)
at com.sun.corba.se.impl.naming.cosnaming.TransientNameServer.<clinit>(TransientNameServer.java:63)

If I search for LogStrings I find that the jre/lib directory has a resources.jar file that contains LogStrings.properties file. I tried rerunning with the classpath explicitly containing this file but got the same result.

Looking at my build output shows this file being processed but no unusual errors or warnings.

Anyone seen this, or able to offer any insight?
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!