Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem while running Tomcat

 
Priya chek
Ranch Hand
Posts: 51
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
when i tries to run my servlet program iam getting error like this in console. Iam using oracle-10g database7 i have copied jar file of oracle-10g express edition in to lib folder & i updated buld path. Iam using Jdk 7& Oracle 7..can we use Oracle 7 instead of oracle 10 g express edition..Actually i dont know what is the actual use of Oracle 7 that i have.should i use Oracle 7 when iam using jdk 7?? help me ..appreciating your help..waiting for reply..



Jul 04, 2013 9:27:18 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-7-oracle/jre/lib/i386/server:/usr/lib/jvm/java-7-oracle/jre/lib/i386:/usr/lib/jvm/java-7-oracle/jre/../lib/i386:/usr/lib/jvm/java-7-oracle/jre/lib/i386/client:/usr/lib/jvm/java-7-oracle/jre/lib/i386::/usr/java/packages/lib/i386:/lib:/usr/lib
Jul 04, 2013 9:27:18 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:Project Lists' did not find a matching property.
Jul 04, 2013 9:27:18 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:Project List1' did not find a matching property.
Jul 04, 2013 9:27:18 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:TodaysCrush' did not find a matching property.
Jul 04, 2013 9:27:18 AM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:Jsp Works' did not find a matching property.
Jul 04, 2013 9:27:18 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jul 04, 2013 9:27:18 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 966 ms
Jul 04, 2013 9:27:18 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jul 04, 2013 9:27:18 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.32
Jul 04, 2013 9:27:19 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jul 04, 2013 9:27:19 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Jul 04, 2013 9:27:19 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/32 config=null
Jul 04, 2013 9:27:19 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 568 ms
/usr/lib/jvm/java-7-oracle/bin/java: symbol lookup error: /usr/lib/jvm/java-7-oracle/jre/lib/i386/libJdbcOdbc.so: undefined symbol: SQLAllocEnv
 
Vivek Kr Agrawal
Ranch Hand
Posts: 51
Eclipse IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I don't think Oracle or any of its version has anything to do with this problem. Please check the tomcat server once again. You can try deleting and creating the server instance in eclipse again.
Just search for the error message and you will find plenty of answers in various sites.
Just check this stackoverfow it may be useful.
 
Ulf Dittmer
Rancher
Posts: 42968
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
None of this looks serious to me. Do you have indications of an actual problem?

The only thing that looks strange is "/usr/lib/jvm/java-7-oracle/jre/lib/i386/libJdbcOdbc.so" - it indicates the use of the JDBC/ODBC bridge (and not any Oracle DB). How are you specifying the DB to use?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic