Win a copy of Five Lines of Code this week in the OO, Patterns, UML and Refactoring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

New to web services

 
Ranch Hand
Posts: 483
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,

I started learning Web Services. I wrote my first piece of code from the example that was given in the book. But when i run it, it does not behanve the way its supposed to! I see the wsdl file generated and see the error:



I googled for this, but could not find too many concrete stuff. The one's i found did not help.

Here is the WSDL file:





I am not sure what other information to provide, if you need anything just ask. I am using Tomcat 7.0
 
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Somnath,

Are you getting the error while accessing the webservice from a client. If such please post your client code.

Thanks,
Kesava
 
Somnath Mallick
Ranch Hand
Posts: 483
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, I haven't reached that far yet. I see this error when i try to open the wsdl file in a browser.
 
Kesava Krishna
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you let me know how are you trying to access the wsdl, I mean the url you are using to launch the wsdl.

Thanks,
Kesava.
 
Somnath Mallick
Ranch Hand
Posts: 483
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well i deployed the code on Tomcat. Then started the application on a browser. Went to the Services section, then got the wsdl URL from there. And copy pasted it on another tab.

This is what i saw in the browser as the WSDL URL:

http://localhost:9090/WSTestOther/services/WSNewTestImplService
 
Somnath Mallick
Ranch Hand
Posts: 483
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Where is the edit button??

Anyways, I see this error in the console:

 
    Bookmark Topic Watch Topic
  • New Topic