• Post Reply Bookmark Topic Watch Topic
  • New Topic

can't find solution

 
Kenneth Van Gysegem
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi everybody,

I'm making a website, and I have a problem.
I'll first post the code and then elaborate on my problem, it must be something small that I am
overseeing as I do not get any errors.


this class also has getters and setters for every propertie (i havn't incorporated that because it would take up to much space).




the servletclass


this is the jsp

Now on to my problem:
when I run the weppage there is space reserved for each propertie I call in the last <c:forEach> of the JSP

but there is no value placed as if all el-statements return an empty string.
I have looked and looked for what might be the problem, but havn't found the solution.
If anyone coud help me in the right direction or give me a hint I would be very gratefull.
Thanks in advance,
Kenneth

P.S. if anyone needs more info feel free to ask
 
Ivan Jozsef Balazs
Rancher
Posts: 992
5
  • Likes 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator



The contructor sets only one field, voorstellingsNr, the others do not appear to be set. How are they supposed to get values?
 
Kenneth Van Gysegem
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OMG! you are so right!!!
Damn that's a really stupid mistake!
I have overlooked it somehow focussing on the other parts of my code.
Damn, i feel a bit ashamed now

But thank you so much for looking into it, i will be more carefull next time.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!