• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Tim Cooke
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Paul Clapham
  • Rob Spoor
  • Junilu Lacar
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Piet Souris
  • Carey Brown
Bartenders:

Error while running my first spring application

 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a beans.xml file

What is the significance of the following lines?

I tried changing the value of "http://www.springframework.org/schema/beans/spring-beans-3.0.xsd" to spring-beans-4.0.xsd and it is throwing errors like the following:


Why is it running fine when I have spring-beans-3.0.xsd or spring-beans-2.5.xsd. But throwing errors when I have spring-beans-4.0.xsd. Please explain.

thanks,
thiru
 
author & internet detective
Posts: 41502
881
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
That is the version number of Spring. For example, Spring 3 or 2.5

There is no Spring 4.0 available yet. There is a development version of Spring 4.0, but it isn't completed yet. If you are learning Spring, I recommend you use Spring 3 at this time. It is stable and comes with lots of documentation, tutorials and help online.
 
reply
    Bookmark Topic Watch Topic
  • New Topic