• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Spring security sample is not working? Please help.

 
Ranch Hand
Posts: 177
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Trying to run a very basic spring-security demo but not able to login into app. Seems to be a configuration issue but not able to figure it out. Please help.
I am using Spring 3.2 and Spring Security 3.1
For convenience, I have pasted the code below and attached as well. Hope it will help or please let me know in case of any other query.
The URL I am hitting is "http://localhost:8080/SpringSecurity/home". It is opening the automatic login form but even after providing the correct credentials (admin/password), it is coming on the same page again!!! I have attached log file for tomcat console. It contains log for Tomcat load as well as hitting the url and then login. Link for WAR is also given, in case you want to try.
UPDATE: Not able to attach here so uploaded on rapidshare.com Below are links:
http://rapidshare.com/files/146621860/security_log.txt
http://rapidshare.com/files/3127127598/pom.txt
http://rapidshare.com/files/3340242913/SpringSecurity.war


web.xml


Spring-MVC-servlet.xml


SpringSecurity-servlet.xml


HomeController.java



home.jps



Thanks.
 
shai ban
Ranch Hand
Posts: 177
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Problem should be jar/configuration only as I just updated for below working example and it also didn't work!!!
http://www.mkyong.com/spring-security/spring-security-hello-world-example/

I updated Spring core libraries to 3.2.3.RELEASE and Spring securities jar to 3.1.4.RELEASE. And it stopped working!!!

Still, I don't have any idea how to fix.
 
shai ban
Ranch Hand
Posts: 177
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My bad. The problem was in the IE browser where I had highest security and I didn't test it in another browser.

Thanks.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!