• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

iReport text field some text in bold not working

 
Ranch Hand
Posts: 114
1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a textField

$F{X} + " and"


I want the string "and" to be displayed in bold.
I googled and found few answers like : usage of <b> OR

$F{X} + "<style isBold=\"true\" pdfFontName=\"Helvetica-Bold\">Bolt text</style>"

but when the result appears like a normal text : $F{X} <style isBold=\"true\" pdfFontName=\"Helvetica-Bold\">Bolt text</style>

What am I doing wrong?
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'm not sure about your version of IReport, but I'm using the 4.0.0 and it works if you set up the property "Markup" of the Textfield to html.
Then you can use like:
$F{X} + "<b>Bolt text</b>"

att
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic