• Post Reply Bookmark Topic Watch Topic
  • New Topic

wss4j incompatibility between cxf and axis1.4

 
Frank Hamilton
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am deploying some client for my application. I use cxf for develop the client, but the last client consume a service made with rpc type, so it hasn't got compatibility with axis2 or cxf. Then I use axis1.4 to generate the client. All my client use wss4j for security purpose, but cxf need wss4j1.6 and axis1.4 need wss4j1.5. Now, I have a problem with library incompatibility.

Could someone help me with this issue?

Thank.
 
Edson Cezar
Ranch Hand
Posts: 119
2
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had a resembling problem, then as my application used CXF and the client used AXIS 1.4, and was impossible change it.

Then I built a bridge, I developed a Server/Client in Axis 2 for communicate with CXF and AXIS 1.4.

Like this way:

CXF --> AXIS2 --> AXIS 1.4
 
Frank Hamilton
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Edson,

it is not the solution which most like to me but I think that in this moment it is the better.

Thanks, again.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!