Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

problem calling webservice in weblogic but tomcat works fine

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everyone,

I am facing problem in calling webservice in my project which is deployed in weblogic. but the same application works fine in tomcat deployment.

Error:
javax.xml.ws.WebServiceException: Failed to access the WSDL at: http://xxx.xxx.xxx.xx:8111/XXXX/services?wsdl. It failed with:
Response: '401: Unauthorized' for url: 'http://xxx.xxx.xxx.xx:8111/xxx/services?wsdl'.

But same works fine in tomcat deployment...

i search in the net. people said, we need to force weblogic to use sun http handler, so written something like below. but its not works for me.

sun.net.www.protocol.http.Handler handler = new sun.net.www.protocol.http.Handler();
URL wsdlURL = new URL(null, "http://xxx.xxx.xxx.xx:8111/xxx/services?wsdl", handler);

please help me to solve this issue. i am in urgent...
 
Ranch Hand
Posts: 1376
Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to Javaranch !!
Few questions
a. Please place web service client code here and full exception stacktrace
b. how is the web service is deployed in weblogic ? as Servlet ? as EJB component ?
c. please clarify where are your web service client code and web service implementation is deployed? in weblogic ? in tomcat ? are you trying to call web service (deployed in weblogic)
d. please clarify what steps you have done on Tomcat for successful deployment and working

Seem like you are using very basic Service classes to call Web service

thanks
abhay
 
I'm sure glad that he's gone. Now I can read this tiny ad in peace!
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic