Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Error 100 MediaPlayer died

 
Maykel John
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
When I try to read a rtsp video stream from a GenyMotion device (Galay Nexus 4.3), I get the following error 100, Media server died. I don't know what is happening, I have the internet permissions and I have opened my RTSP link with VLC.




I/System.out(1317): -----> Player started
D/libEGL(1317): loaded /system/lib/egl/libEGL_genymotion.so
D/(1317): HostConnection::get() New Host Connection established 0xb8dea260, tid 1317
D/libEGL(1317): loaded /system/lib/egl/libGLESv1_CM_genymotion.so
D/libEGL(1317): loaded /system/lib/egl/libGLESv2_genymotion.so
W/EGL_genymotion(1317): eglSurfaceAttrib not implemented
E/OpenGLRenderer(1317): Getting MAX_TEXTURE_SIZE from GradienCache
E/OpenGLRenderer(1317): Getting MAX_TEXTURE_SIZE from Caches::initConstraints()
D/OpenGLRenderer(1317): Enabling debug mode 0
D/MediaPlayer(1317): Couldn't open file on client side, trying server side
W/MediaPlayer(1317): info/warning (701, 0)
I/MediaPlayer(1317): Info (701,0)
W/AudioSystem(1317): AudioFlinger server died!
W/IMediaDeathNotifier(1317): media server died
E/MediaPlayer(1317): error (100, 0)
E/MediaPlayer(1317): Error (100,0)
D/VideoView(1317): Error: 100,0
W/EGL_genymotion(1317): eglSurfaceAttrib not implemented
D/dalvikvm(1317): GC_FOR_ALLOC freed 129K, 2% free 9196K/9348K, paused 20ms, total 21ms

 
Maykel John
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey does someone have an idea ? I'm still confronted to this :/
 
Steve Luke
Bartender
Posts: 4181
22
IntelliJ IDE Java Python
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No idea, really, but I did some searching and those that find answers to the problem always seem to indicate the problem was on the server, or that there was no content. So:
1) Are you sure the URL is correct
2) Are you sure the authentication is correct
3) Are you sure the stream you are loading exists
4) Are you sure there is no redirect to a different URL that you aren't following?
5) Are you sure your phone has access to the URL/internet
6) Have you checked the server to see if it logs errors (if you have access to it)
7) Have you tested with something that is in a similar arrangement as the phone. For example you said you tested on a VLC, but was that test done from the Android device? From a system that was on an external network relative to the server? etc...
 
Maykel John
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Steeve. In fact I connect on an ipcam which deals with RTSP. This is pretty nice because we don't need any server. So it's a direct access. I've tried

1 -> 3 : Yes
4 : No, but I don't think so. RTSP is managed by the ip camera.
5 : Yes. Internet permissions are set to ok and I can use the browser
6 : No, but I'm gonna see if it's possible *
7 : with VLC Beta and RTSP Viewer :
-> Galaxy S2 2.3.3 : nothing works
-> Cubit (chinese phone, not mine) Android 4.1.x : RTSP Viewer didn't work but VLC did

* EDIT : I only have access to the interface connections logs (when I connect to the back office), which is not very usefull
 
Martin Taillefer
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I know it's been a while, but I'm wondering if you ever found a solution to this problem?

I'm trying to use MediaPlayer in Marshmallow to play an RTSP stream from a LILIN camera, and I'm getting the same failures. The camera doesn't generate an audio stream, only a video stream, and I'm guessing that's why I'm also seeing the AudioFlinger server dying. I tried to find a way to turn off audio processing in MediaPlayer but didn't find anything there. By changing the URL, I can play RTSP streams off the Internet. And I can run VLC from the same device to play the stream from the camera. So it's not basic connectivity or simple configuration problems. The problem really seems to be about the particular RTSP stream being played.

Thanks for any pointers.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic