Win a copy of Java EE 8 High Performance this week in the Java/Jakarta EE forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

WSSecurityException: General security error (No certificates for user were found for signature)  RSS feed

Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I am using Axis 1.5 and WSS4j 1.5 (I know, old), and It can't find my private key I've listed in my KeyStore. I have tried finding the PrivateKey by SHA1 Hash, and also by Certificate Alias.

This question has been asked before on StackExhange, but their problem, was that their certificate type in the KeyStore wasn't a "PrivateKeyEntry". Mine is. See:

My Crypto File:


I have tried combinations of both

For both "user", and "signatureUser".

Here is my Password Callback Class:

However, when I do all of this programatically (setup my own handlers, initiate a WSSecBuilder, and do a Builder.setUserInfo(User, Pw), It can find the PrivateKey O.K.

I have tried everything possible, has anyone else ever had this problem? Or does anyone know something that I may be doing wrong? A known bug with the older axis'? I've tried different keystore types, pkcs12, etc, and all yield the same error.... "General security error (No certificates for user"

Any help would be greatly appreciated! I am pulling my hair out.

Look ma! I'm selling my stuff!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!