This week's book giveaways are in the AI and JavaScript forums.
We're giving away four copies each of GANs in Action and WebAssembly in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of GANs in ActionE this week in the AI forum
or WebAssembly in Action in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
  • Knute Snortum
Sheriffs:
  • Liutauras Vilda
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Joe Ess
  • salvin francis
  • fred rosenberger

Struts

 
Ranch Hand
Posts: 52
Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
my problem is ... struts tag is not supporting ... waht may be possible error ? my jsp page was very simple

i am using netbeans and i already included struts framework at time of project creation....but i i m pressing ctl+space no help is occuring ... after manual written not supporting.

Thanks
 
Pramod Kumar Pandey
Ranch Hand
Posts: 52
Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
and one Strange thing ( at least for me ) is happening , when I open IDE then only once it show hint for struts tag in welcomeStruts.jsp, once i save this.. again it doesn't show hint again in the same page (with ctl+space) I am unable to get whats going on actually ?. Really i get helped many seniors, but they had not. please guide me .
 
author & internet detective
Posts: 39789
797
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What happens if you type <ht:form></ht:form> by hand and run the page? Does it print "htLform" or convert to <form>? If the later, it is just your autocomplete that isn't working and not a big deal. If the former, your web project is probably set up wrong.
 
Bartender
Posts: 9612
16
Mac OS X Linux Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This sounds more like a Netbeans questions than a Struts question.
First, don't use Struts 1 if you can at all help it. Struts 1 has not had a new release since 2008 and there will be no further support. Any other "modern" framework will be much more productive than Struts 1.
Next, use use "html" rather than "ht" as the prefix for the Struts HTML taglib. This way, others will not get distracted by your unconventional prefix and can focus on your code.
I'll move this topic to the IDE forum where hopefully someone more skilled with Netbeans can chime in.
 
Pramod Kumar Pandey
Ranch Hand
Posts: 52
Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jeanne Boyarsky wrote:What happens if you type <ht:form></ht:form> by hand and run the page? Does it print "htLform" or convert to <form>? If the later, it is just your autocomplete that isn't working and not a big deal. If the former, your web project is probably set up wrong.


sir I tell you what is happening now... 1. I opened index.jsp . 2. I added tag library of struts. 3. as soon as i start typing <prefix ( just prefix name only) a list is opened (hint ) but as i type : after prefix name then hint gone off and no hint will show in further ( even after repeating the same process again.). Sir I am really get weired ... what I do ?>
 
Pramod Kumar Pandey
Ranch Hand
Posts: 52
Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sir I consulted one My senior, he suggested me to uninstall first netbeans then uninstall jdk..... then install both again... It is now working properly( while I already tried by only uninstallation of netbeans but that was not working.) but due to which it was I didn't get still... Thanks to all attension.
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Glad to know you got it working, although I'm pretty sure it had nothing to do with the JDK install/uninstall that you did.
 
Time is mother nature's way of keeping everything from happening at once. And this is a tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!