Win a copy of Spring in Action (5th edition) this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Knute Snortum
  • Junilu Lacar
  • paul wheaton
Saloon Keepers:
  • Ganesh Patekar
  • Frits Walraven
  • Tim Moores
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Stephan van Hulst
  • salvin francis
  • Tim Holloway

Data Source COnfiguration in Jboss jboss-eap-6.1  RSS feed

 
Ranch Hand
Posts: 87
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am Migrating my Application to jboss-eap-6.1
I am Trying to configure the Oracle Data Source
I have copied the ojdbc6.jar into the following directory
JBOSS_HOME/modules/com/oracle/ojdbc6/main
Along with the jar i have created module.xml as below

<?xml version="1.0" encoding="UTF-8"?>
<module xmlns=xm lns="urn:jboss:module:1.0"" name="com.oracle.jdbc">
<resources>
<resource-root path="ojdbc6.jar"/>
</resources>
<dependencies>
<module name="javax.api"/>
</dependencies>
</module>


And i Have COnfigure my Driver inside drivers tag as below

</driver>
<driver name="oracle" module="com.oracle.ojdbc6">
</driver>


And My Datasource Configuration is as follows

<datasource jndi-name="java:jboss/datasources/MYDS" pool-name="MYDS" enabled="true" use-java-context="true">
<connection-url>jdbcracle:thin:@localhost:1521/MYXE</connection-url>
<driver-class>oracle.jdbc.OracleDriver</driver-class>
<driver>oracle</driver>
<security>
<user-name>MYORA</user-name>
<password>MYORA</password>
</security>
</datasource>


I get the following Exception When i start the server

ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 25) JBAS014613: Operation ("add") failed - address: ([
("subsystem" => "datasources"),
("jdbc-driver" => "oracle")
]) - failure description: "JBAS010441: Failed to load module for driver [com.oracle.ojdbc6]"


Any Suggestions on how to overcome this issue

Thanks in Advance
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

<module xmlns=xm lns="urn:jboss:module:1.0"" name="com.oracle.jdbc">



This name doesn't match with the module name that you have specified in the driver configuration and that's why you are seeing that error.
 
chicha sonu
Ranch Hand
Posts: 87
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks jaikiran..
I tried the changes as said by you which are mentioned below
Driver Configuration
<driver name="oracle" module="com.oracle.ojdbc6">
Module
<?xml version="1.0" encoding="UTF-8"?>
<module xmlns=xmlns="urn:jboss:module:1.0"" name="com.oracle.ojdbc6">
<resources>
<resource-root path="ojdbc6.jar"/>
</resources>
<dependencies>
<module name="javax.api"/>
</dependencies>
</module>
But i still get the same error....

 
chicha sonu
Ranch Hand
Posts: 87
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I even tried copying the oracle folder into h2database and tried to do the same where h2 drivers have been installed ,but still getting the same error..please let me know where am i comiting the mistake

folder Structure:modules\system\layers\base\com\h2database\oracle\main\
Inside Main i have ojdbc6.jar and module.xml
Module.xml
<?xml version="1.0" encoding="UTF-8"?>
<module xmlns="urn:jboss:module:1.1" name="com.h2database.oracle">
<resources>
<resource-root path="ojdbc6.jar"/>
</resources>
<dependencies>
<module name="javax.api"/>
<module name="javax.transaction.api"/>
</dependencies>
</module>
Driver Configuration
</driver>
<driver name="oracle" module="com.h2database.oracle">
</driver>
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I see that this topic has been requested for being marked as solved. Can you please post your solution here so that others know what to do when they run into similar problem?
 
chicha sonu
Ranch Hand
Posts: 87
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have gone through the below mentioned URL .I helped me and also saved my time

http://middlewaremagic.com/jboss/?p=872
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!