• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can Robotium Recorder create scripts for Android versions prior to 16?

 
Andrew Monkhouse
author and jackaroo
Marshal Commander
Pie
Posts: 12007
215
C++ Firefox Browser IntelliJ IDE Java Mac Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I noticed in some test scripts that the minimum version of Android was set to 16 (JellyBean). It crashes immediately on a Kindle Fire(!) . It does work very well, however, on a Genymotion virtual device.

Is there any way to get scripts created to target earlier releases of Android? Or is this fixed because of the latest version of Robotium?
 
Renas Reda
Robotium Recorder Support
Greenhorn
Posts: 5
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Robotium supports API Level 7 and up. You can change the minimum API level in the AndroidManifest.xml of the created test project to whatever you like (7 or higher). Robotium Recorder sets the minimum value based on the lowest version of the Android SDK installed on the computer that is recording the tests.
 
Consider Paul's rocket mass heater.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic