• Post Reply Bookmark Topic Watch Topic
  • New Topic

Cannot get an Arquillian test from a Tutorial to run

 
Fred Funks
Greenhorn
Posts: 10
Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello community,

I am a Java EE beginner and I am currently trying out the official JBoss-tutorials. I'm doing everything exactly like the author says here http://www.jboss.org/jdf/quickstarts/jboss-as-quickstart/guide/KitchensinkQuickstart/ , but the Arquillian Test at the end of the tutorial is just not running.
At the end of the test, a feedback should be displayed, that a new user was successfully registered.

When I try the "remote mode", it just says "INFO [org.jboss.as.repository] (management-handler-thread - 2) JBAS014900: Content added at location /usr/local/share/jboss/standalone/data/content/39/43f4a6358db043a9709f62370fecd34c2111ca/content".
In the JUnit View it says "Runs: 0/0".

When i try the "managed mode", it just complains, that the JBoss server is already running.

I really hope, that you can help me. I will also ask the author of the tutorial.
 
Fred Funks
Greenhorn
Posts: 10
Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Forgot to mention:

I am using Ubuntu Linux, JBoss 7.1 and Eclipse. I also tried it under Windows, but the same thing happens.
 
Fred Funks
Greenhorn
Posts: 10
Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have left a comment on the tutorial, but it seems like the author wasn't there for months, so you guys are my only hope!
 
Jaikiran Pai
Sheriff
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
KakTyc Fox wrote:
In the JUnit View it says "Runs: 0/0".


It looks like no test methods are found in that test. Can you post the testcase code including the import statements?
 
Fred Funks
Greenhorn
Posts: 10
Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Jaikiran Pai wrote:
It looks like no test methods are found in that test. Can you post the testcase code including the import statements?


Sure:



You can also find the code and the instructions on the webpage, I indicated in the first post.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!