Win a copy of The Journey To Enterprise Agility this week in the Agile and Other Processes forum! And see the welcome thread for 20% off.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

problem in spring mvc with jqgrid and JPA  RSS feed

 
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
i am trying spring mvc with jpa and jqgrid as given in the tutorial in the link :https://github.com/krams915/spring-jqgrid-tutorial/.

i have done everything as told in the link( given as a maven project), but i have included the dependencies and created a dynamic web project.
I am getting the following exception:


i am including the complete stack trace:



what is the possible cause. Please help me.
 
Nikhy Pai
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, i think what i posted yesterday was insufficient to find out the error.

I am attaching my project explorer and list of jar files in the lib folder.
Also my xml files are as follows:

applicationContext.xml



spring-data.xml


spring-servlet.xml



web.xml



spring.properties



orm.xml



persistence.xml


I hope this would be sufficient .
Please any help would be appreciated.
ProjectExplorer.png
[Thumbnail for ProjectExplorer.png]
ProjectExplorer
lib1.png
[Thumbnail for lib1.png]
Jarfiles
lib2.png
[Thumbnail for lib2.png]
Jarfiles
 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi , it say's that it didn't find your persistence configuration. check inside your deployed war if the META-INF directory is under classes and it contains your persistence.xml file.
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!