Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Error resolving version for plugin 'org.codehaus.mojo:maven-war-plugin' from the repositories ?

 
Peter Cong
Ranch Hand
Posts: 44
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I use eclipse indigo new version to build Seam web project with Maven integration option, after the project is created, I got this error in my POM file.

Error resolving version for plugin 'org.codehaus.mojo:maven-war-plugin' from the repositories [local (C:\Users\Jon\.m2\repository), jboss-public-repository-group (https://repository.jboss.org/nexus/content/groups/public/), central (http://repo1.maven.org/maven2)]: Plugin not found in any plugin repository

Does anybody know how to fix it? thanks a lot,
 
Tim Holloway
Saloon Keeper
Pie
Posts: 18224
53
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try asking in the Maven forum. You'll find more experts there.

Moving this thread over to the Maven forum...
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think there is a typo in your POM - the group id for maven-war-plugin is org.apache.maven.plugins, not org.codehaus.mojo.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic