Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Neoclipse Exception - Database Error

 
ashwini hirlekar
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have created nodes and relationships in java using Neo4j jars,I am trying to display the same from Neoclipse, I am getting Exception when trying to create connection from Neoclipse to the folder created by java program (I am using windows 7) . Exception:
java.lang.IllegalStateException:Mismatching store version found(v0.A.1 while expecting v0.A.0)
and the store is not cleanly shutdown.
Recover the database with previous database version and then attempt to upgrade .
after this i added graphDb.shutdown(); code then i got different exception:

org.neo4j.kernel.impl.storemigration.StoreUpgrader$UnableToUpgradeException:
Not all store Files match the version required for successful upgrade.
List of jar files:
geronimo-jta_1.1_spec-1.1.1.jar
lucene-core-3.6.2.jar
neo4j-2.0.1.jar
neo4j-cypher-2.0.1.jar
neo4j-graph-algo-2.0.1.jar
neo4j-graph-matching-2.0.1.jar
neo4j-jmx-2.0.1.jar
neo4j-kernel-2.0.1.jar
neo4j-lucene-index-2.0.1.jar
neo4j-udc-2.0.1.jar
 
Bill Gorder
Bartender
Posts: 1682
7
Android IntelliJ IDE Linux Mac OS X Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Last I checked NeoEclipse is not compatible with Neo4j 2.x yet.

I see they have now closed this issue
https://github.com/neo4j-contrib/neoclipse/pull/59

However they have not released a compatible build yet. You could try building it from source if you wanted.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic