• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

How to deploy jforum using oracle with apache tomcat?

 
Roy Marpaung
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to connect jforum using oracle 11g with apache tomcat, but it doesn't work.
I fill DataSource name : jforum,but i have error "Name [jforum] is not bound in this Context. Unable to find [jforum]."

Please help me

Best regards

Roy Marpaung
 
Ulf Dittmer
Rancher
Posts: 42968
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to JavaRanch. How have you set up that DataSource?
 
Steve Hazeldine
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you don't bother with the data source route but specify (database server) host name, port (default is 1521) and database service name then connections work just fine.

If you do that it looks as if a connection pool with 5 connections is created. Plenty for testing but one should dig deeper into the pool config if a busy site is anticipated.

Of course, if digging deeper it may be that you want to use a completely different approach to connection pooling anyway because if your web site(s) are already using an oracle database, you would in principle be better of with just one connection pool and not several. But that's way beyond the scope of your question so enough.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic