This week's book giveaway is in the Artificial Intelligence forum.
We're giving away four copies of Pragmatic AI and have Noah Gift on-line!
See this thread for details.
Win a copy of Pragmatic AI this week in the Artificial Intelligence forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

[Liferay 6.2] SassToCssBuilder has got NullPointerException,  RSS feed

 
Greenhorn
Posts: 3
Hibernate Oracle Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there,

Now, I have problem when I build portlet to war file in eclipse.

Env:
- liferay-plugins-sdk-6.2.0
- liferay-portal-6.2-ce-ga2

Issue: use eclipse to build the portlet to war file successfully, but I have the error:
build-css:
[java] Loading jar:file:/home/tomcat-7.0.53/webapps/ROOT/WEB-INF/lib/portal-impl.jar!/system.properties
[java] Loading jar:file:/home/tomcat-7.0.53/webapps/ROOT/WEB-INF/lib/portal-impl.jar!/portal.properties
[java] java.lang.NullPointerException
[java] at com.liferay.portal.tools.SassToCssBuilder._parseSassDirectory(SassToCssBuilder.java:222)
[java] at com.liferay.portal.tools.SassToCssBuilder.<init>(SassToCssBuilder.java:144)
[java] at com.liferay.portal.tools.SassToCssBuilder.main(SassToCssBuilder.java:94)

Please, give me any suggestion to fix this problem!

I am waiting for all you help!
Thanks and Kind Regards,
 
Sheriff
Posts: 3015
12
Firefox Browser IntelliJ IDE Java Mac Ruby
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi anh (or chị) Tu, welcome to JavaRanch!

That's actually posted as a bug against Liferay 6.2 on Ubuntu. Link to bug report. Unfortunately, it's been closed as "no longer reproducible". It's dealing with daily frustrations like these that makes software development such an exciting field. Can you upgrade to a newer version of Liferay, or Ubuntu if that's in fact what you're using? Another line of attack is looking at the Liferay source code at that spot (i.e., SassToCssBuilder.java, line 222) to see what's going wrong.

Also, Liferay has its own forums, where you may find a more concentrated population of Liferay experts. If you do re-post your question there though, please just let us know in this thread. That's one of the few rules we have here. (Click ⇒ BeForthrightWhenCrossPostingToOtherSites) Thanks!
 
Tu Ngo
Greenhorn
Posts: 3
Hibernate Oracle Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear Greg Charles,

Thanks for your suggestion! We have found the root cause is the Tomcat server that we changed. It miss something. So, we have to use the Tomcat server of Liferay-portal to build the portlet to pass that error.

Thanks,
Regards,
Mr. Tu Ngo.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!