• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Is it a bug in Eclipse 4.3

 
Adarsh Singhal
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've created Dynamic Web Project in Eclipse 4.3 & then I'm trying create a Servlet but Next or Finish Button is not activated in Servlet Dialogbox. Is it a bug or I'm missing something.
bug.png
[Thumbnail for bug.png]
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65123
91
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I would assume that it's because you left the package blank -- servlets rarely work if they are not in an explicit package. (But I wouldn't know for sure as I don't use an IDE to generate code for me.)
 
Adarsh Singhal
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Filling Package text field doesn't make any difference. There is default package if you leave it blank.
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34860
369
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Adarsh,
Welcome to CodeRanch!

I just tried that wizard in Kepler. I didn't need to enter a package name (although I agree with Bear that you should.) One thing I noticed is that when I typed in the classname in the field (where you have it), the class name was automatically filled in under the bottom Class Name box.

It's really easy to create a servlet though so I think your best bet it to just create the servlet class without the wizard.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic